Can't install drivers for Sentinel HL

3 posts / 0 new
Last post
DHopkins
Can't install drivers for Sentinel HL

Hi,

I'm running VirtualHere client vhui64.exe v5.1.6 on a Windows Server 2016 Hyper-V VM, connecting to VirtualHere Server vhusbdwin64.exe, also v5.1.6, on a Windows Server 2016 Hyper-V host. I did not install Bonjour on the server, since this is a very straightforward permanent network connection and I didn't see any need for a discovery service.

I'm trying to forward a SafeNet Sentinel HL copy protection hardware dongle from the physical host to the VM. The application which uses the dongle comes with the Sentinel System Driver Installer version 7.5.8. I've installed that driver package on both the physical host and the VM guest. When I look in the server-side Windows Device Manager, I can see the Sentinel key listed, with a correctly installed driver.

The VirtualHere client can connect to the server and can see the "Sentinel HL" device attached to the server's hub. When I double-click the "Sentinel HL" to use it in the client OS, I get "Error 2 installing drivers, The system cannot find the file specified."

VH shows me the following log entries (which cover multiple attempts to connect the dongle, I think):


2021-03-19 07:51:07 INFO :Server ping timeout, shutting down connection 1...
2021-03-19 07:51:07 INFO :Connection 1 socket closed (rx)
2021-03-19 07:51:23 INFO :No drivers found, they will be installed
2021-03-19 07:51:27 INFO :SetupDiEnumDeviceInterfaces failed
2021-03-19 07:51:27 ERROR :Hub failed to open error, No more data is available. (0x00000103)
2021-03-19 08:14:36 INFO :In file ../src/msw/window.cpp at line 593: 'SetFocus' failed with error 0x00000057 (The parameter is incorrect.).
2021-03-19 08:15:53 INFO :No drivers found, they will be installed
2021-03-19 08:16:31 INFO :SetupDiEnumDeviceInterfaces failed
2021-03-19 08:16:31 ERROR :Hub failed to open error, No more data is available. (0x00000103)

The USB device properties are:

VENDOR: SafeNet Inc.
PRODUCT: Sentinel HL
VENDOR ID: 0x04B9
PRODUCT ID: 0x0300
ADDRESS: 8

No one is using this device

Any advice on what I might need to do to get this to work?

DHopkins
Solved, I think

I found relevant tips in an old forum post here: https://www.virtualhere.com/content/virtual-here-client-driver-enumerato...

I uninstalled the Sentinel USB drivers from the host OS instance, and uninstalled VirtualHere using vhui64.exe -y and restarted everything, and now the Sentinel HL is mapping correctly into the guest OS.

Michael
.

Great thanks for letting me know

Log in or register to post comments