Client 5.1.2 cannot run as a Windows service

13 posts / 0 new
Last post
MarkoD
Client 5.1.2 cannot run as a Windows service

Hi, I've been using version 5.1.1 running as a Windows serivce sucessfully. I've updated the binary to 5.1.2 and now the service cannot start. I've restarted Windows, uninstalled and reinstalled the client as a service, however the problem persists. When I try to start the service manually, I get this error message:

"The VirtualHere Client USB Sharing service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other service or programs."

When I uninstall and reinstall the service, VirtualHere shows me these two messages when it tries to restart in service mode:

(Application title: Vhui64-512)
"80703,79687,0"
"Timeout waiting the VirtualHere Client USB Sharing service to start"

Windows Event Viewer shows no logs from the VirtualHere client. When I replace the .exe with version 5.1.1, the service starts okay without any problems.

PS: When I start 5.1.2 as a stand-alone under my (admin) user account, it runs okay. I'm using the same configuration .ini file for both stand-alone and service.

Michael
.

What version of windows are you using?

MarkoD
Windows 10 Pro and Windows 7

Windows 10 Pro and Windows 7 Pro. I know 7 is not supported, but it happens on 10 also.

Michael
.

Thanks, i found the bug , it was to do with the internationalization fix i did yesterday for chinese characters.

I will fix this today and roll out a new 5.1.3 version this evening. (I have rolled back to 5.1.1 temporarily on my website)

MarkoD
Thanks, Michael, for the

Thanks, Michael, for the quick fix and great work!

Michael
.

OK should be fixed now in 5.1.3 of the client

MarkoD
I've tried 5.1.3,

I've tried 5.1.3, unfortunately now the service just takes too long to start and gives the following error after a timeout:

"Error 1053: The service did not respond to the start or control request in a timely fashion"

Michael
.

You must uninstall 5.1.2 server first, dont just stop it

vhui64.exe -u

then reboot then run vhui64.exe -i

MarkoD
Thanks, that did the trick,

Thanks, that did the trick, now the service is working okay. I notice that the service startup parameter has changed from "-s" to "-n", I guess that's why I needed to reinstall the service?

Michael
.

Yes, i had to remove the -s argument for technical reasons.Thats why you needed to uninstall the old then install the new service, i just assumed you were already doing that when you upgrade as the service exe is locked normally by the service manager.

pragosadti
Timeout

Hello, I'm having this issue in Windows Server 2019 and also Windows Server 2008 R2. I can't seem to start the service, when I install the client as a service it gives me a couple messages and won't start.

"325531,324515,0
Timeout waiting the VirtualHere Client USB Sharing service to start"

Michael
.

You cannot just copy over the new exe because the arguments have changed.

You must do as mentioned in the previous post

Uninstall the 5.1.2 service first

vhui64.exe -u

then reboot then run vhui64.exe -i

pragosadti
Can't start service

Seems like the day I tried to fix this I was still downloading version 5.1.2. It was now updated and the service starts fine.

Thanks

Log in or register to post comments