No Connection to a SpaceMouse from 3dconnexion possible

10 posts / 0 new
Last post
Thomas Hünerberg
No Connection to a SpaceMouse from 3dconnexion possible

Hello,
I am trying to make a USB connection to the client with Virtual Here Server 4.3.6 in the demo version.

This works fine with an SD card reader, a hard disk, mouse, and keyboard.
Unfortunately I can't connect to a SpaceMouse. (https://3dconnexion.com/de/product/spacemouse-wireless/)

The client reports "There was a error using this device" and the server log says

2022-02-10 09:01:45 INFO :Connection 2 successfully removed (reason:server shutdown)
2022-02-10 09:01:47 INFO :Unmanaging device 9 [256f:c62f]
2022-02-10 09:01:50 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-10 09:01:50 INFO :Found Full speed device [256f:c62f] "3Dconnexion, SpaceMouse Wireless Receiver" at address 9
2022-02-10 09:02:24 INFO :192.168.0.48 connected as connection 3
2022-02-10 09:03:07 ERROR :Error 50 calling hub powercycle for device 9, Die Anforderung wird nicht unterstützt. (0x00000032)
2022-02-10 09:03:07 WARNING :Device never reappeared!
2022-02-10 09:03:07 ERROR :Error binding device 9 [256f:c62f] to connection 3, BIND_ERROR

What can I do to make it work?

Michael
.

Try plugging the wireless mouse it directly into the PC with the usb cable and use it via virtualhere that way. Dont use it wirelessly, i think from memory wireless has issues via virtualhere.

Thomas Hünerberg
Thanks for the quick reply.

Thanks for the quick reply.
I have now connected the SpaceMouse via a cable, unfortunately it brings no success.
Next week I will have another, exclusively wired Spacemouse here and then test again whether this then works.

2022-02-10 11:48:29 ERROR :Error 50 calling hub powercycle for device 10, Die Anforderung wird nicht unterstützt. (0x00000032)
2022-02-10 11:48:29 WARNING :Device never reappeared!
2022-02-10 11:48:29 ERROR :Error binding device 10 [256f:c62e] to connection 5, BIND_ERROR

Michael
.

OK let me know if the wired one works ok. Thanks.

Thomas Hünerberg
Test of 4 different models Space mice from 3Dconnexion

Hello Michael,
I have now 4 different Space Mice from 3Dconnexion here and tested them all. From each test I have always restarted the USB server and then tried to connect the mouse on the client. Unfortunately, this has not succeeded with any mouse.

I would be very happy about a solution. My plan is to use the 3D mouse from the home office to control a CAD software via RDP. This would probably also work via remote FX if the group policies are changed for this. Unfortunately this is not possible because our company forbids this. Therefore I am looking for another solution and so I came to Virtual Here.

Thomas

SpaceMouse Compact

2022-02-17 07:21:20 INFO :Connection 1 successfully removed (reason:server shutdown)
2022-02-17 07:21:22 INFO :Unmanaging device 1 [0b05:179c]
2022-02-17 07:21:22 INFO :Unmanaging device 9 [04b8:013d]
2022-02-17 07:21:22 INFO :Unmanaging device 3 [0d8c:0014]
2022-02-17 07:21:22 INFO :Unmanaging device 4 [25a7:fa10]
2022-02-17 07:21:22 INFO :Unmanaging device 5 [0b0e:0420]
2022-02-17 07:21:22 INFO :Unmanaging device 6 [0c45:636d]
2022-02-17 07:21:22 INFO :Unmanaging device 11 [256f:c635]
2022-02-17 07:21:24 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-17 07:21:25 ERROR :Error loading string descriptor (not string) for device on port 7
2022-02-17 07:21:25 ERROR :Error loading string descriptor (not string) for device on port 2
2022-02-17 07:21:25 WARNING :Loading string descriptor for device on port 2 failed, Ein an das System angeschlossenes Gerät funktioniert nicht. (0x0000001f)
2022-02-17 07:21:25 INFO :Found Full speed device [0b05:179c] "0x0b05, 0x179c" at address 1
2022-02-17 07:21:25 INFO :Found High speed device [04b8:013d] "EPSON, 0x013d" at address 9
2022-02-17 07:21:25 INFO :Found Full speed device [0d8c:0014] "C-Media Electronics Inc., USB Audio Device" at address 3
2022-02-17 07:21:25 INFO :Found Full speed device [25a7:fa10] "Nordic, 2.4G Wireless Receiver" at address 4
2022-02-17 07:21:25 INFO :Found Full speed device [0b0e:0420] "0x0b0e, Jabra SPEAK 510 USB" at address 5
2022-02-17 07:21:25 INFO :Found High speed device [0c45:636d] "PC-LM1E, PC-LM1E" at address 6
2022-02-17 07:21:25 INFO :Found Low speed device [256f:c635] "3Dconnexion, SpaceMouse Compact" at address 11
2022-02-17 07:21:45 INFO :192.168.0.44 connected as connection 2
2022-02-17 07:22:24 ERROR :Error 50 calling hub powercycle for device 11, Die Anforderung wird nicht unterstützt. (0x00000032)
2022-02-17 07:22:24 WARNING :Device never reappeared!
2022-02-17 07:22:24 ERROR :Error binding device 11 [256f:c635] to connection 2, BIND_ERROR

SpaceMouse Pro

2022-02-17 07:23:32 INFO :Connection 2 successfully removed (reason:server shutdown)
2022-02-17 07:23:32 INFO :Connection 2 successfully removed (reason:timeout)
2022-02-17 07:23:34 INFO :Unmanaging device 1 [0b05:179c]
2022-02-17 07:23:34 INFO :Unmanaging device 9 [04b8:013d]
2022-02-17 07:23:34 INFO :Unmanaging device 3 [0d8c:0014]
2022-02-17 07:23:34 INFO :Unmanaging device 4 [25a7:fa10]
2022-02-17 07:23:34 INFO :Unmanaging device 5 [0b0e:0420]
2022-02-17 07:23:34 INFO :Unmanaging device 6 [0c45:636d]
2022-02-17 07:23:34 INFO :Unmanaging device 11 [256f:c635]
2022-02-17 07:24:10 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-17 07:24:11 ERROR :Error loading string descriptor (not string) for device on port 7
2022-02-17 07:24:11 ERROR :Error loading string descriptor (not string) for device on port 2
2022-02-17 07:24:11 WARNING :Loading string descriptor for device on port 2 failed, Ein an das System angeschlossenes Gerät funktioniert nicht. (0x0000001f)
2022-02-17 07:24:11 INFO :Found Full speed device [0b05:179c] "0x0b05, 0x179c" at address 1
2022-02-17 07:24:11 INFO :Found High speed device [04b8:013d] "EPSON, 0x013d" at address 9
2022-02-17 07:24:11 INFO :Found Full speed device [0d8c:0014] "C-Media Electronics Inc., USB Audio Device" at address 3
2022-02-17 07:24:11 INFO :Found Full speed device [25a7:fa10] "Nordic, 2.4G Wireless Receiver" at address 4
2022-02-17 07:24:11 INFO :Found Full speed device [0b0e:0420] "0x0b0e, Jabra SPEAK 510 USB" at address 5
2022-02-17 07:24:11 INFO :Found High speed device [0c45:636d] "PC-LM1E, PC-LM1E" at address 6
2022-02-17 07:24:11 INFO :Found Low speed device [046d:c62b] "3Dconnexion, SpaceMouse Pro" at address 12
2022-02-17 07:24:18 INFO :192.168.0.44 connected as connection 3
2022-02-17 07:24:58 ERROR :Error 50 calling hub powercycle for device 12, Die Anforderung wird nicht unterstützt. (0x00000032)
2022-02-17 07:24:58 WARNING :Device never reappeared!
2022-02-17 07:24:58 ERROR :Error binding device 12 [046d:c62b] to connection 3, BIND_ERROR

SpacePilot PRO

2022-02-17 07:25:59 INFO :Connection 3 successfully removed (reason:server shutdown)
2022-02-17 07:26:00 INFO :Unmanaging device 1 [0b05:179c]
2022-02-17 07:26:00 INFO :Unmanaging device 9 [04b8:013d]
2022-02-17 07:26:00 INFO :Unmanaging device 3 [0d8c:0014]
2022-02-17 07:26:00 INFO :Unmanaging device 4 [25a7:fa10]
2022-02-17 07:26:00 INFO :Unmanaging device 5 [0b0e:0420]
2022-02-17 07:26:00 INFO :Unmanaging device 6 [0c45:636d]
2022-02-17 07:26:00 INFO :Unmanaging device 12 [046d:c62b]
2022-02-17 07:27:03 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-17 07:27:04 ERROR :Error loading string descriptor (not string) for device on port 7
2022-02-17 07:27:04 ERROR :Error loading string descriptor (not string) for device on port 2
2022-02-17 07:27:04 WARNING :Loading string descriptor for device on port 2 failed, Ein an das System angeschlossenes Gerät funktioniert nicht. (0x0000001f)
2022-02-17 07:27:04 INFO :Found Full speed device [0b05:179c] "0x0b05, 0x179c" at address 1
2022-02-17 07:27:04 INFO :Found High speed device [04b8:013d] "EPSON, 0x013d" at address 9
2022-02-17 07:27:04 INFO :Found Full speed device [0d8c:0014] "C-Media Electronics Inc., USB Audio Device" at address 3
2022-02-17 07:27:04 INFO :Found Full speed device [25a7:fa10] "Nordic, 2.4G Wireless Receiver" at address 4
2022-02-17 07:27:04 INFO :Found Full speed device [0b0e:0420] "0x0b0e, Jabra SPEAK 510 USB" at address 5
2022-02-17 07:27:04 INFO :Found High speed device [0c45:636d] "PC-LM1E, PC-LM1E" at address 6
2022-02-17 07:27:04 INFO :Found High speed device [046d:c629] "3Dconnexion , SpacePilot PRO " at address 13
2022-02-17 07:27:22 INFO :192.168.0.44 connected as connection 4
2022-02-17 07:27:40 ERROR :Error 50 calling hub powercycle for device 13, Die Anforderung wird nicht unterstützt. (0x00000032)
2022-02-17 07:27:40 WARNING :Device never reappeared!
2022-02-17 07:27:40 ERROR :Error binding device 13 [046d:c629] to connection 4, BIND_ERROR

SpaceMouse Wireless (connected with cable)

2022-02-17 07:29:50 INFO :Connection 4 successfully removed (reason:server shutdown)
2022-02-17 07:29:52 INFO :Unmanaging device 1 [0b05:179c]
2022-02-17 07:29:52 INFO :Unmanaging device 9 [04b8:013d]
2022-02-17 07:29:52 INFO :Unmanaging device 3 [0d8c:0014]
2022-02-17 07:29:52 INFO :Unmanaging device 4 [25a7:fa10]
2022-02-17 07:29:52 INFO :Unmanaging device 5 [0b0e:0420]
2022-02-17 07:29:52 INFO :Unmanaging device 6 [0c45:636d]
2022-02-17 07:29:52 INFO :Unmanaging device 10 [256f:c62e]
2022-02-17 07:29:53 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-17 07:29:54 ERROR :Error loading string descriptor (not string) for device on port 7
2022-02-17 07:29:54 ERROR :Error loading string descriptor (not string) for device on port 2
2022-02-17 07:29:54 WARNING :Loading string descriptor for device on port 2 failed, Ein an das System angeschlossenes Gerät funktioniert nicht. (0x0000001f)
2022-02-17 07:29:55 INFO :Found Full speed device [0b05:179c] "0x0b05, 0x179c" at address 1
2022-02-17 07:29:55 INFO :Found High speed device [04b8:013d] "EPSON, 0x013d" at address 9
2022-02-17 07:29:55 INFO :Found Full speed device [0d8c:0014] "C-Media Electronics Inc., USB Audio Device" at address 3
2022-02-17 07:29:55 INFO :Found Full speed device [25a7:fa10] "Nordic, 2.4G Wireless Receiver" at address 4
2022-02-17 07:29:55 INFO :Found Full speed device [0b0e:0420] "0x0b0e, Jabra SPEAK 510 USB" at address 5
2022-02-17 07:29:55 INFO :Found High speed device [0c45:636d] "PC-LM1E, PC-LM1E" at address 6
2022-02-17 07:29:55 INFO :Found Full speed device [256f:c62e] "3Dconnexion, SpaceMouse Wireless" at address 10
2022-02-17 07:30:26 INFO :192.168.0.44 connected as connection 5
2022-02-17 07:30:45 ERROR :Error 50 calling hub powercycle for device 10, Die Anforderung wird nicht unterstützt. (0x00000032)
2022-02-17 07:30:45 WARNING :Device never reappeared!
2022-02-17 07:30:45 ERROR :Error binding device 10 [256f:c62e] to connection 5, BIND_ERROR

Thomas Hünerberg
Additional info

I have done the tests in the Local network. Both PCs are connected directly to a FritzBox (Router) via Lan

PC1: Windows 10 Enterprise 21H2 with VH Server
PC2: Windows 11 Pro 21H2 Client

Both Pc's are set to German

emcee2
Hello

Hello
I doubt I have a solution for you... it's just a shot in the dark but I might as well mention it:

Have you installed the 3D Connexion driver software on both ends? For some reason I seem to recall I had to do that. That is, I already had the driver software installed on my work machine as I have another 'Space' device installed there, but I seem to recall (~ 2 years ago) that I had to install the driver on my home machine as well.

However, I am running a different configuration: a wired SpaceNavigator into a hub on macOS; MS Remote Desktop Client to work computer (Windows 10). I use the controller for SolidWorks and some other apps.

For what it is worth; the error part of the log file does make me think there is an issue with the power time out on that USB device for whatever reasons. I do see on the 3D connexion forum various comments/issues with Windows 11.

Thomas Hünerberg
Hello emcee2

Hello emcee2
thank you for your hints. That means for me that the connection works for you with a Spacemous from 3D Connexion.
I had already installed the driver on both PCs, but not the same versions were installed. Unfortunately a reinstallation of the current driver 10.8.5 was not successful.

Can you please tell me which version of the driver you have installed. I would also like to know your version of Virtual here.

Thank you

Michael
.

Try this, Uninstall the spacemouse drivers entirely from the machine where the mouse is physically plugged in (the server). Reboot the server then try again

Thomas Hünerberg
Problem solved

Uninstall the spacemouse drivers on the Server side solve the problem and it works with the wireless one in the local network.

For the test on my CAD PC I need unfortunately first the support of our IT since I have there no admin rights to connect with the client the device. I will then test whether the connection works reliably after the connection is established and give you feedback. Thanks for your support

Log in or register to post comments