Problem with the last release

15 posts / 0 new
Last post
javiercico
Problem with the last release

Hello,

I was using vhusbdarm 3.4.7 since September on a dd-wrt router without problem. I have decided to upgrade the binary to the lastest version 3.5.5

For the same config or another clean, it doesn't work on the same machine. If I revert back to 3.4.7 it works again.

Here is the syslog:

Mar 8 07:25:17 XXXXXXX user.info vhusbdarm.new[5576]: >>> Starting VirtualHere USB Server v3.5.5 (Built: Feb 27 2018, 13:57:05)<<<
Mar 8 07:25:17 XXXXXXX user.info vhusbdarm.new[5576]: Using configuration /opt/bin/config.ini
Mar 8 07:25:17 XXXXXXX user.info vhusbdarm.new[5577]: >>> Shutdown <<<

As I said, the same command with the same config in the same machine, with 3.5.5 works. I use the free version.

Any idea?

Thank you!

Michael
.

Try to run the new version then when it stops do this

echo $?

and tell me what it says

javiercico
Hello,

Hello,

With the old version 3.4.7:

root@XXXXXXX:/opt/bin# ./vhusbdarm
VirtualHere USB Server is running...press CTRL-C to stop
^CStopping... <---------------------- It keeps waiting until I press CTRL-C
root@XXXXXXX:/opt/bin# echo $?
0
root@XXXXXXX:/opt/bin#

With the new version 3.5.5:

root@XXXXXXX:/opt/bin# ./vhusbdarm.new
root@XXXXXXX:/opt/bin# echo $?
9
root@XXXXXXX:/opt/bin#

Thank you

Michael
.
javiercico
Hello Michael,

Hello Michael,

I have tried it and it didn't work, it happens exactly the same.

Could you put some message on the output or in the syslog?

I can try as many times as you want, I have no problem with that.

javiercico
Hello,

Hello,

Still not working. I have tried with the new version 3.5.6 without success.

Should I give up?

Thank you

Michael
.

use 3.4.7 for the time being as i cannot work on this issue at this time, in a week or two ill look at your issue again...

javiercico
Hello Michael,

Hello Michael,

Ok No problem.

Meanwhile, may I ask you a favour? Could you please send me the releases between 3.4.7 and 3.5.5?

3.5.4 (1st Feb 2018)
3.5.3 (19th Jan 2018)
3.5.2 (16th Jan 2018)
3.5.1 (30th Dec 2017)
3.5.0 (18th Dec 2017)
3.4.9 (12th Dec 2017)
3.4.8 (25th Nov 2017)

I will test each release and then we will know exactly the relase and changeset that contains the issue, This may help you to fix it.

Thank you Michael.

Michael
.

Can you try 3.5.7 and see if it makes a difference

javiercico
Hello,

Hello,

There's no diffence, still not working.

I think that in order to delimit the issue, the fastest way could be to test all versions from 3.4.7. You only have to send me the files and I will try them.

Thank you for your help :)

javiercico
Hello,

Hello,

The version 3.6.0 still not working.

Thank you.

javiercico
Hello Michael,

Hello Michael,

The version 3.6.4 is still not working.

Thank you!

Michael
.

OK, in the system log when you try to start the server does it show any messages about the reason?

I added some logging in version 3.6.4 of the server to log in more details any startup issues.

javiercico
Hello Michael,

Hello Michael,

I have tried again the version 3.6.4 and now it's working. It didn't work on the previous attemp because I made a mistake trying the old version 3.6.0, which didn't work.

So, summarizing, from the version 3.4.8 to 3.5.5 you did a change and the application didn't work anymore on arm32. And there is a change from the version 3.6.1 to 3.6.4 that makes the application working again.

Thank you!!!

Michael
.

OK great im glad its all working for you now

Log in or register to post comments