SSH connection problem

9 posts / 0 new
Last post
andreynech
SSH connection problem

Hi Folks,

I am using server v.3.6.9 on Pi0w and can not connect with SSH. I am getting login prompt, but neither root/<empty> nor root/cloudhub66 works (access denied).
I would appreciate if someone running server on Pi0w can confirm that SSH connection works and there is no regression.

Thank you and best regards,
Andrey.

andreynech
.

Here are the relevant server logs:

Wed Aug 8 15:52:02 2018 authpriv.info dropbear[942]: Child connection from 192.168.32.244:55677
Wed Aug 8 15:52:07 2018 authpriv.warn dropbear[942]: Bad password attempt for 'root' from 192.168.32.244:55677
Wed Aug 8 15:52:08 2018 authpriv.warn dropbear[942]: Bad password attempt for 'root' from 192.168.32.244:55677
Wed Aug 8 15:52:09 2018 authpriv.warn dropbear[942]: Bad password attempt for 'root' from 192.168.32.244:55677
Wed Aug 8 15:52:09 2018 authpriv.info dropbear[942]: Exit before auth (user 'root', 3 fails): Max auth tries reached - user 'root' from 192.168.32.244:55677

Michael
Hi Andrey,

Hi Andrey,

The pi0w cloudhub firmware now remembers your settings previously set. So if you turned off ssh it wont work by default after you re-write the sdcard.

If you need to reset everything back to factory defaults, connect pin 1 and pin 40 for 3 seconds

andreynech
.

Hi Michael,
I understand your point. However, I can not connect over SSH even with absolutely new installation (after dd to sd-card) and enabled SSH.
Does it works for you?

Michael
.

Yes it works fine. I just retested by doing this

1. Downloaded the cloudhub pi0w image from https://www.virtualhere.com/hardware
2. Used etcher to write the sdcard with the image
3. Put it in the pi0w and powered it on
4. About 10 seconds later the pi0 appeared on my network (because it remembers the previous configuration which was for my network) and appeared in my virtualhere client.
5. Used a paperclip to connect pin1 and pin40 for 3 seconds
6. Pi0w disappears from the network
7. Comes back with its own network CloudHub_xxxxx
8. Use another wifi adapter to connect to this network
9. Pi appeared again in my virtualhere client
10. Used putty to ssh to the pi0w, and it succeeded

I think you have some other network issue. If you follow the steps above it will work for you also.

andreynech
.

Thank you for clarifications! I will try to reproduce them.

Just out of curiosity - you said "Used etcher to write the sdcard with the image", so I assume that there is nothing left on the sdcard from previous installation. Then you write " About 10 seconds later the pi0 appeared on my network (because it remembers the previous configuration". I am wondering where/how it remembers previous configuration? 8-o I mean, it is a new image so where the previous configuration is coming from?!

Michael
.

Yes im not sure myself now it remembers the previous settings when the sdcard is entirely erased!

I changed the disk format from ext4 to squashfs in 3.6.9 of the cloudhub firmware and from then on the configuration is remembered between sd card writes

andreynech
.

Could it be that *your* configuration (i.e. ssh password) is somehow stored in the new image as the default one? In this case it could be the reason why I can not connect with ssh.

Michael
.

No that is impossible. Dont forget the ssh signature might change so putty might warn the ssh key was changed. If you are ignoring this message by turning off alerts or something then you wont see this message from putty and you will fail to connect

When you connect pin 1 and pin 40 for 3 seconds it will remove any previous configuration and return the password to cloudhub66

Log in or register to post comments