Usb Bluetooth dongle issues

11 posts / 0 new
Last post
ipokampo
Usb Bluetooth dongle issues

Hi,
I'm having a hard time trying to make my BT devices properly work through USB BT Dongle connected to a Nvidia shield.

Server is Android v3.2.8 (licensed for unlimited devices)
Client is Windows 10 x64 v4.1.7
BT dongles i've tried so far(x3): 2 different branded CSR 8510A10 and an Asus BT400
BT devices i've tried so far(x4): 2 different Xbox One BT Controller, DualShock4 v1 & DualShock4 v2

All of the devices cause the same issue no matter how i connect them or try them out, to the point that i've managed to isolate the problem, and to my understanding it is virtualHere the one causing the issue, i'll further explain it:

The problem is that all of the bt devices mentioned, can be paired just fine with any of the bt dongles used, and so far they work perfectly, BUT once the devices are shutted off OR the computer is restarted OR the shield is restarted, any of these events cause the bt devices to not be able to reconnect to the dongle (at least not without a lot of effort)
To be able to connect them again, I have to start/stop the bt devices i'd say in average 5/6 times till they get recognized by windows again, sometimes i get too tired of trying and just unpair the device and re-pair it holding the sync buttons again, and whilst repairing works at 1st try, it's a bummer to have to do it every time I want to use my bt controllers.
Also note that once connected, the controllers are completely functional, no lag or any other thing, at least until they are shutted off for one more time ending with the same problem.

The thing is none of this happens if I try any of the dongles with any of the bt devices directly from my computer, this only occurs when bt dongles are used from the nvidia shield through the virtualHere server, so that leads me to think is this piece of software the one causing this issue.

Just as a hint, sometimes when a controller is finally reconnected, I can see in the Bluetooth devices control panel showing as "Connected" but windows does not show any gamepad controller in the Gamepads devices list so, my guess is that the bt device got finally recognized, but some bt service did not work (or any other issue) causing windows to not be able to register the gamepad properly.

Anyway, this is all a bummer for me, as i mostly play my games from the shield with these controllers so I'd be more than happy if you fix this.
I'll be glad to help with log files or any other thing to clear this out.
Thx

Michael
.

Can you plug in one of the bluetooth dongles into the sheild, then go to the virtualhere client and right cick on the dongle and select Custom Event Handler... and enter

onReset.$VENDOR_ID$.$PRODUCT_ID$=

then press ok. Now try to use the dongle via virtualhere. Any improvment? Some bluetooth dongles like to have firmware uploaded when they start. But this can be skipped as long as a USB reset is not issued. The command above skips the usb reset command so in theory the dongle should work ok.

ipokampo
Hey Michael,

Hey Michael,
thanks for your fast response. I did what you suggested but sadly without success, the re-connecting problem is still there. I've tried another thing which is to run the client as a service in windows, but that did not solve it either.

I think that the bt dongle works just fine, cause windows always recognizes it, I don't think the problem is with the dongle connecting to the virtualClient or the server, I'm starting to think it has something to do with the way the VH server communicates with the clients, maybe there is something during a bt device reconnecting negotiation that goes wrong, or the order in the packages/instructions matter and their getting in the wrong order or some are missing, really I'm just guessing here, but i tend to think it's more something about how BT dongles talk with their devices and to windows, than the dongle connection itself with vh server which i think is fine.

Happy to help with any other idea

ipokampo
Also just so you know the

Also just so you know the more and more i pay attention to the re-connecting cycle, there are a lot of times that windows reports the bt controller as "connected" but either the light in the controller is still blinking (not connected yet) or windows says bt device is connected but no gamepad is connected to windows which is also unusable. Anyways food-for-thought

Michael
.

Can you disable the bluetooth on your pc/laptop, i notice that sometimes if i pass through bluetooth via virtualhere, windows doesnt like a second bluetooth controller so it disables the one coming in via virtualhere. If you disable the on-board bluetooth at the client then the one coming in via virtualhere would become the main and work... To disable the on-board bluetooth, you usually have to bring up device manager, click on the Bluetooth section and right click and "Disable" the devices

ipokampo
No built in bt in this pc,

No built in bt in this pc, there is only 1 bluetooth device which is the dongle connected through VH.

ipokampo
Little update:

Little update:

Ok, I don't know if this makes sense or not, but i think i've found a workaround, at least for now.

I happen to have a xbox 360 wireless adapter connected to the shield and also added to the vh server. These adapter works flawlessly and always connects my xbox 360 controllers at 1st try, i¡ve never had an issue with it. Neither i had issues with the new Xbox One Wireless Controller and the Xbox One Controllers connected to it instead by bluetooth (so this could be a workaround too) I guess the connection type is different than through this adapter.

So here is the workaround i've found (works for both xbox one controller and ds4 through bluetooth):

If before trying to re-connect my bt devices i connect one of my xbox 360 controllers through the wireless receiver (which always connects and registers just fine as xinput0), then, i disconnect this xbox 360 controller, and right after that i connect any of the bluetooth devices (xbox one / ds4) they get recognized inmediately and windows registers the game pad just fine. I've tried 10/10 times to be sure this was a fact :D

At least I think it ease up the things for me for now. Obviously it would be awesome if they could work right away without having to do this every time by hey! at least now is much easier and consistent.

ipokampo
Last thought:

Last thought:

As I said, using the xbox one wireless adapter solves the xbox one controller connection issues. So I've ordered the new Sony Dualshock Wireless adapter from amazon just to try if this also solves the problem with the ds4. I'll update once i find out!

Michael
.

ok let me know...

ipokampo
So bluetooth dongle communications seems to be broken

Hey, updating here.

Yesterday I received my Sony Wireless Dualshock Adapter, and it was just plug 'n play and it was working, no problem at all neither to sync or reconnect the controller. One of the main differences I see is that this adapter, registers the controller in the device control panel and even though you shut off the controller, the device is still shown as registered in windows (whereas with the bt dongle, the devices always were shown like greyed out, like if you had removed the hw)

So finally got my setup working in the Nvidia shield tv with both the Xbox One Wireless Adapter (for the Xbox One Controller) and the Sony DualShock Wireless Adapter ( for the Dualshock 4 v2 Controller)

If you plan to try to fix the bt dongle issues, just let me know i'll try to gather logs or any other useful information you may need.
Thx.

Michael
.

OK im not sure what chipset the sony bluetooth adapter has but i think it probably doesnt need the firmware on connection uploaded, so thats why it works fine.

Log in or register to post comments