USB Connections dropping/timeout on Nvidia Shield TV

15 posts / 0 new
Last post
AndrewHall37
USB Connections dropping/timeout on Nvidia Shield TV

Hi,
When VirtualHere server is running on Shield (v4.0.7 1038) and connecting to Win10 x64 Client (V5.0.0 – Steam Latest Version). After 5-10 mins the VH USB connection all disconnect & get the usb disconnect sound.

If I go back into the Shield on Steam Link nothing is showing in VH tab and have to unplug/replug all USB devices for it to show up again as shared

Tested with just keyboard/mouse receiver and if I don’t use VH Server on Shield the usb connections don’t drop on my Logitech K360/M570 but mouse scaling not working correctly without VH running

Don’t get any USB disconnects with Steam Link hardware but cant use that anymore because of my Wireless Xbox 360 controller lagging it, so I thought I would try the Shield and the controller works great on this, but cant use it because of USB dropping

Getting following in Shield VH Server Log…

Device 1003 [046d:c52b] UNBOUND from connection 1
Connection 1 successfully removed (reason:timeout)
NvCplGetAppProfileSettingInt failed to getINvCplHalService
Connection 3 sussessfully removed (reason:timeout)

Also if I turn on Auto use all these devices on this hub on the client then all USB devices will reconnect after about 30 seconds but will still disconnect after 5-10 minutes again

Can anyone help

Michael
.

I have heard of this before and i think its related to interference between the on-board shield wifi/bluetooth and the additional radio inside the wireless dongle of the logitech.

If possible do you have a USB hub? If so connect the USB hub to the shield with a long USB cable so its as far away from the shield as possible and plug the wireless dongle into that.

That should separate the radios enough so they dont interfere with each other.

Let me know if that solves the problem.

AndrewHall37
Thanks for the reply

But no still got the same problem, I've even tried a wired USB keyboard and mouse plugged straight into the back of the shield (nothing else) and still get the USB devices disconnect after X mins, this happens on desktop & playing game through steam big picture.
If i set the USB devices in VirtualHere Setting in the Steam App on Shield to 'Ignored' (So no devices shown in VirtualHere client) they work fine and don't disconnect???

Michael
.

Ok thats quite strange if everything is on a LAN. From the VirtualHere client when it happens again can you right click USB Hubs->System Messages -> Copy to clipboard and paste the messages in here.

AndrewHall37
All LAN - Logs as requested and thanks

2020-09-11 14:29:27 INFO :VirtualHere Client 5.0.0 starting (Compiled: Apr 8 2020 14:30:18)
2020-09-11 14:29:27 INFO :Client OS is Windows 10 (build 18362), 64-bit edition
2020-09-11 14:29:27 INFO :Using config at C:\Users\Game\AppData\Roaming\vhui.ini
2020-09-11 14:29:27 INFO :IPC available at \\.\pipe\vhclient
2020-09-11 14:29:29 INFO :Drivers are up-to-date
2020-09-11 14:29:29 INFO :Connected to the VirtualHere Client Driver (Version 2)
2020-09-11 14:35:53 INFO :Connection 2 socket closed (rx)
2020-09-11 14:36:21 INFO :Connection 1 remotely disconnected gracefully (rx)
2020-09-11 14:36:32 INFO :Server ping timeout, shutting down connection 1...
2020-09-11 14:37:05 INFO :Could not connect to 192.168.1.11:7575
2020-09-11 14:48:04 INFO :Connection 4 socket closed (rx)
2020-09-11 15:09:04 INFO :Connection 5 receiving msg size didnt complete due to error 10054,
2020-09-11 15:09:15 INFO :Server ping timeout, shutting down connection 5...

Michael
.

I think you have some physical network issue like a loose cable or something. The connection is definitely dropping and reconnecting for some reason

AndrewHall37
Found the problem :)

It wasn’t hardware, but I noticed in the logs it way saying trying to connect to 192.168.1.46, but my Shield is a static IP same as Client PC and these are not in the DHCP range but my Valve Steam Link Box is and it's 192.168.1.46, which is on but in stand by mode as not being used. So for some reason VH or Link box are trying to talk to each other when in standby. Unplugged the power lead on Steam link box and so far no USB disconnects on the Shield TV.
Hope this helps others & thank you for your help

Log if needed…
2020-09-12 08:33:47 INFO :VirtualHere Client 5.0.0 starting (Compiled: Apr 8 2020 14:30:18)
2020-09-12 08:33:47 INFO :Client OS is Windows 10 (build 18362), 64-bit edition
2020-09-12 08:33:47 INFO :Using config at C:\Users\Game\AppData\Roaming\vhui.ini
2020-09-12 08:33:47 INFO :IPC available at \\.\pipe\vhclient
2020-09-12 08:33:48 INFO :Drivers are up-to-date
2020-09-12 08:33:48 INFO :Connected to the VirtualHere Client Driver (Version 2)
2020-09-12 08:33:55 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:34:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:34:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:35:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:35:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:36:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:36:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:37:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:37:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:38:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:38:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:39:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:39:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:40:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:40:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:41:17 INFO :Connection 1 socket closed (rx)
2020-09-12 08:41:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:41:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:42:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:42:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:43:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:43:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:44:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:44:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:45:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:45:54 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:46:24 INFO :Could not connect to 192.168.1.46:7575
2020-09-12 08:57:32 INFO :Server ping timeout, shutting down connection 28...
2020-09-12 08:57:32 INFO :Connection 28 socket closed (rx)
2020-09-12 09:16:48 INFO :Connection 29 receiving msg size didnt complete due to error 10054,
2020-09-12 09:16:57 INFO :Server ping timeout, shutting down connection 29...
2020-09-12 09:33:29 INFO :Connection 30 socket closed (rx)
2020-09-12 10:16:48 INFO :Connection 31 receiving msg size didnt complete due to error 10054,
2020-09-12 10:16:58 INFO :Server ping timeout, shutting do

AndrewHall37
Nope not that just gone again!!!!

Steam Link & PC are next to each other different cables and switch box aswell

2020-09-12 10:52:59 INFO :VirtualHere Client 5.0.0 starting (Compiled: Apr 8 2020 14:30:18)
2020-09-12 10:52:59 INFO :Client OS is Windows 10 (build 18362), 64-bit edition
2020-09-12 10:52:59 INFO :Using config at C:\Users\Game\AppData\Roaming\vhui.ini
2020-09-12 10:52:59 INFO :IPC available at \\.\pipe\vhclient
2020-09-12 10:53:00 INFO :Drivers are up-to-date
2020-09-12 10:53:00 INFO :Connected to the VirtualHere Client Driver (Version 2)
2020-09-12 11:16:47 INFO :Connection 1 receiving msg size didnt complete due to error 10054,
2020-09-12 11:16:58 INFO :Server ping timeout, shutting down connection 1...

AndrewHall37
* Shield TV Not Link

* Shield TV Not Link

AndrewHall37
.

Done a reset to defaults in VH Client as the old Steam Link box IP keep appearing in the ‘Manage Hubs’ section even if I removed it.

So that’s now gone but USB still drops out and now show two Android hubs in VH Client.
Top one looks like an IPv6 Address (Bold-In Use) and bottom hub a IPv4 address both for Shield in the Address field for each ‘Android Hub’, is this correct?

Also no IP address appearing in the logs

Not sure if any of this helps but thanks for your time

2020-09-12 12:08:50 INFO :Drivers are up-to-date
2020-09-12 12:08:50 INFO :Connected to the VirtualHere Client Driver (Version 2)
2020-09-12 12:16:46 INFO :Connection 3 receiving msg size didnt complete due to error 10054,
2020-09-12 12:16:46 INFO :Connection 2 receiving msg size didnt complete due to error 10054,
2020-09-12 12:16:56 INFO :Server ping timeout, shutting down connection 3...
2020-09-12 12:16:58 INFO :Server ping timeout, shutting down connection 2...
2020-09-12 12:46:46 INFO :Connection 4 receiving msg size didnt complete due to error 10054,
2020-09-12 12:46:46 INFO :Connection 5 receiving msg size didnt complete due to error 10054,
2020-09-12 12:46:55 INFO :Server ping timeout, shutting down connection 4...
2020-09-12 12:46:56 INFO :Server ping timeout, shutting down connection 5...

Michael
.

Error 10054 is a winsock error (windows tcp networking library) which means, " An existing connection was forcibly closed by the remote host"

That full message is probably not that helpful for you but it means something between the server/client is dropping the connection.

Do you have a spare network cable anyway just to plug in instead between the boxes?

AndrewHall37
.

Still got the same problem even after moving my PC and shield next to the router disabled wifi checked that they are the only attached devices connected to the network both on new cat 6 cables???
Think I'm going to give up on this atm, but big thank you anyway

Michael
.

Yes sorry i dont know what else to try

weetbixnmilk
Did you find a solution?

I am experiencing this issue currently on the Nvidia Shield. The "Shield TV" USB Hub disappears for 30 secs then reconnects.

Michael
.

You have a network issue, use an ethernet cable and not wifi

Log in or register to post comments