USB key is not mounted when using SSL

11 posts / 0 new
Last post
9081160
USB key is not mounted when using SSL

Hey.
The USB key is not mounted when using SSL, everything works fine without the SSL.
How to solve this problem?
Thanks for answers.

Device: Pi4
System: ubuntu 20.4 server

Michael
.

Sounds like a licensing issue. SSL wont work with the free version of the server.

Take a look in the server syslog and client system messages and see if it shows anything there

9081160
.

the license was bought a few days ago and EasyFind too.

Log with SSL:
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2257]: >>> Starting VirtualHere USB Server v4.2.0 (Built: Jul 27 2020, 11:37:47)<<<
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2257]: Using configuration /root/config.ini
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2272]: Using SSL Server certificate at /home/ubuntu/server.pem
Sep 2 07:45:27 ubuntu systemd[1]: Started LSB: Start VirtualHere USB Sharing on boot.
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2272]: Server licensed to=10000000XXXXXXXXX max_devices=unlimited
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2272]: Using large URB's
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2272]: Listening on all network interfaces at TCP SSL port 7574 (IPv6 dual-stack)
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2272]: Your EasyFind Id : XXXXXXXXXXXXXXXX
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2272]: Your EasyFind Pin: XXXXXX
Sep 2 07:45:27 ubuntu vhusbdarmpi4[2272]: Found Full speed device [15cf:0019] "Avtor, SecureToken" at address 113
Sep 2 07:47:51 ubuntu vhusbdarmpi4[2272]: 192.168.0.204 connected as connection 1
Sep 2 07:47:53 ubuntu kernel: [ 135.592599] usb 1-1.3: reset full-speed USB device number 3 using xhci_hcd
Sep 2 07:47:53 ubuntu vhusbdarmpi4[2272]: Device 113 [15cf:0019] BOUND to connection 1
Sep 2 07:47:54 ubuntu kernel: [ 136.044618] usb 1-1.3: reset full-speed USB device number 3 using xhci_hcd
Sep 2 07:48:25 ubuntu vhusbdarmpi4[2272]: Device 113 [15cf:0019] UNBOUND from connection 1
Sep 2 07:48:25 ubuntu vhusbdarmpi4[2272]: Error 22 discarding urb 0x286550 for device /sys/bus/usb/devices/1-1.3, Invalid argument (abort endpoint)
Sep 2 07:48:25 ubuntu kernel: [ 166.952288] usb 1-1.3: usbfs: process 2293 (vhusbdarmpi4) did not claim interface 0 before use
Sep 2 07:48:25 ubuntu vhusbdarmpi4[2272]: Error 22 discarding urb 0x286550 for device /sys/bus/usb/devices/1-1.3, Invalid argument (abort endpoint)

2020-09-02 07:47:49 INFO :VirtualHere Client 5.0.7 starting (Compiled: Jul 27 2020 12:10:38)
2020-09-02 07:47:49 INFO :Client OS is Windows 10 (build 19041), 64-bit edition
2020-09-02 07:47:49 INFO :Using config at C:\Users\ZEN\AppData\Roaming\vhui.ini
2020-09-02 07:47:49 INFO :IPC available at \\.\pipe\vhclient
2020-09-02 07:47:49 INFO :Using SSL CA File C:\ca.pem
2020-09-02 07:47:49 INFO :Auto-find (Bonjour) on
2020-09-02 07:47:49 INFO :Auto-find (Bonjour SSL) on
2020-09-02 07:47:52 INFO :Drivers are up-to-date
2020-09-02 07:47:52 INFO :Connected to the VirtualHere Client Driver (Version 2)

Log without SSL:
Without SSL everything works fine here

Sep 2 07:55:12 ubuntu vhusbdarmpi4[2242]: >>> Starting VirtualHere USB Server v4.2.0 (Built: Jul 27 2020, 11:37:47)<<<
Sep 2 07:55:12 ubuntu vhusbdarmpi4[2242]: Using configuration /root/config.ini
Sep 2 07:55:12 ubuntu systemd[1]: Started LSB: Start VirtualHere USB Sharing on boot.
Sep 2 07:55:13 ubuntu vhusbdarmpi4[2263]: Server licensed to=10000000XXXXXXXXX max_devices=unlimited
Sep 2 07:55:13 ubuntu vhusbdarmpi4[2263]: Using large URB's
Sep 2 07:55:13 ubuntu vhusbdarmpi4[2263]: Listening on all network interfaces at TCP port 7575
Sep 2 07:55:13 ubuntu vhusbdarmpi4[2263]: Your EasyFind Id : XXXXXXXXXXXXXXXX
Sep 2 07:55:13 ubuntu vhusbdarmpi4[2263]: Your EasyFind Pin: XXXXXXXXXXX
Sep 2 07:55:13 ubuntu vhusbdarmpi4[2263]: Found Full speed device [15cf:0019] "Avtor, SecureToken" at address 113
Sep 2 07:57:13 ubuntu vhusbdarmpi4[2263]: Device 113 [15cf:0019] BOUND to connection 1
Sep 2 07:57:14 ubuntu kernel: [ 96.884304] usb 1-1.3: reset full-speed USB device number 3 using xhci_hcd
Sep 2 07:57:26 ubuntu vhusbdarmpi4[2263]: Device 113 [15cf:0019] UNBOUND from connection 1
Sep 2 07:57:26 ubuntu kernel: [ 108.865493] usb 1-1.3: usbfs: process 2279 (vhusbdarmpi4) did not claim interface 0 before use

2020-09-02 08:02:21 INFO :VirtualHere Client 5.0.7 starting (Compiled: Jul 27 2020 12:10:38)
2020-09-02 08:02:21 INFO :Client OS is Windows 10 (build 19041), 64-bit edition
2020-09-02 08:02:21 INFO :Using config at C:\Users\ZEN\AppData\Roaming\vhui.ini
2020-09-02 08:02:21 INFO :IPC available at \\.\pipe\vhclient
2020-09-02 08:02:21 INFO :Auto-find (Bonjour) on
2020-09-02 08:02:21 INFO :Auto-find (Bonjour SSL) on
2020-09-02 08:02:25 INFO :Drivers are up-to-date
2020-09-02 08:02:25 INFO :Connected to the VirtualHere Client Driver (Version 2)

Michael
.

The SSL log does show the client connecting ok.

192.168.0.204 connected as connection 1

Do you see the USB key in the client when using SSL? And you selected "Use" for that dongle and it appears in Windows Device Manager?

(VirtualHere over SSL is identical to the non-ssl mode except that a TCP (or UDP) socket is wrapped in a TLS envelope, so behaviour should be identical)

9081160
.

I see the USB key in the client, but when connected, it does not appear in Windows Device Manager when using ssl,
without ssl it is displayed in Windows Device Manager and works fine

Michael
.

It must be something unrelated to virtualhere. There is no difference between the two modes in virtualhere so its not possible for it to be blocked. It might be something to do with RDP? Are you using RDP to access the client pc? That will block some dongles

9081160
.

no i don't use RDP

I have Ubuntu 64-bit installed
I'll check for 32-bit, maybe this is the problem on Pi4

9081160
.

also does not work with ssl in 32-bit
what else could be the problem?

Michael
.

I dont think its related to virtualhere. I cannot see how its possible because the software works identically whether via ssl or normal socket.

9081160
.

Hello.
how to use ssl in cloudhub-bcm27xx-bcm2711-rpi-4-squashfs-factory.img, if possible?

Michael
.

I think its something on your client side, not the server side.

Log in or register to post comments