Windows server - ignoredevices

9 posts / 0 new
Last post
trickyb_uk
Windows server - ignoredevices

Michael,

Have just started setting up the windows server after installing the licence... I appreciate the windows VH is still in development...

The windows machine (Win7 x64) we're using has three devices attached (mouse, keyboard, printer).

Keyboard - 45E/DD
Mouse - 45E/39
Printer - 3F0/4E17

I tried ignoring all three through the client which initially got rid of the mouse and printer, but only amended the config.ini with the details of the keyboard and mouse!

So I manually added the printer VID/PID and restarted the server at which point all three devices were available again.

IgnoredDevices=45E/DD,45E/39,3F0/4E17

Very odd.

Richard

trickyb_uk
...additionally

FYI ...as I'm working through, I've also noted that,using the same config.ini format as under Linux, the ClientIdMap doesn't appear to work on the windows server at the moment, either.

Richard

trickyb_uk
strange behaviour

...odd, but after the third time of editing the config.ini with our ClientIdMap info, that function now seems to be working.

On the two previous occasions, that data had 'vanished' from the file!

I know what you're thinking... "He didn't save the config.ini after editing!" - to which I counter; i copied the edited file it from the desktop and over-wrote the original once I had stopped and shut VH down.

Hence, stange behaviour.

So... it's just the IgnoredDevices function causing an issue at the moment.

Thanks

Richard

Michael
You need to stop and

You need to stop and completely exit the server before editing the config.ini file, because the server writes the config.ini at random times when its running so it will just overwrite whatever you have changed.

trickyb_uk
I honestly thought I had...

My error.

However, that just leaves the IgnoredDevices issue.

Richard

Michael
Ok actually you can just

Ok can you right click on the devices in the client and select "Ignore...", then post what the server puts in the config.ini after you've done that, i think it might be a CRLF thing in windows..

trickyb_uk
That's where I'm up to.

As per the OP, using the client to 'Ignore...' only removes two of the the three devices - and all three return upon a restart of the server.

Oddly, whilst the printer does get ignored, its VID/PID are not entered into the config.ini. Manually editing the config.ini with details of all three doesn't work either.

All three devices return in the client list upon server restart, and the keyboard can never be ignored by either process.

Richard

Michael
ok should be fixed now in 2.9

ok should be fixed now in 2.9.4 of the server, download it and give it a try...

trickyb_uk
Brilliant!

That done it. Thanks

Sorry to keep you awake!!

Richard

Log in or register to post comments