Xbox wireless adapter

14 posts / 0 new
Last post
jkoros
Xbox wireless adapter

I'm having trouble getting my Xbox Wireless Adapter to enter "pairing" mode when plugged in to my nvidia Shield (2019 pro).

When I plug it in, it appears to be recognized by the server on the Shield and passed to the client on my windows 10 host.

It also recognizes the adapter and drivers are properly installed.

When I try to connect turn on the controller though, the light never turns on for the adapter.

I have already connected my controller to the adapter dongle directly from a win 10 pc and it works as expected.

This is the version adapter I have.
https://www.amazon.com/Microsoft-Xbox-Wireless-Adapter-Windows-Packaging...

Do I just need to buy the new version?
I'm stumped.

Thanks!

Michael
.

1. Can you try another USB port on the shield.

If that still doesn't work

2. Hold the sync button for 2 seconds on the dongle and see if that wakes it up

jkoros
.

Nope, neither port works, nor does an A to A usb extender cable.

When I press or hold the sync button, I get no light flash.

The system log show an error when I click the button.
"InputEventReceiver: Attempted to finish an input event but the input event receiver has already been disposed."
Also getting repeated "E libnvcpl_vendor: NvCplGetAppProfileSettingInt failed to get INvCplHalService" whether I press the button or not.

Picture, since can't copy the log text from shield.
https://imgur.com/a/1tT4HKl

jkoros
.

Nope, neither ports, nor an A to A USB extender cable.

No lights with short or long press on the adapter.

Log giving a repeated error for failed to get INvCplHalService whether I press button or not.
When I press the button, I get a log at the timestamp which says W InputEventReceiver: Attempted to finish an input event but the input event receiver has already been disposed.

Can't figure out how to copy the log file from my shield, so here's a picture.
https://imgur.com/a/1tT4HKl

Michael
.

OK dont know sorry, VirtualHere works fine with those adapters, might be something weird with that adapter. I assume its a genuine adapter and not a no-name copy

jkoros
.

Yes, genuine adapter, just the first-gen fatter one from MS.

Are there any other logs I should look for?
Are the errors I posted meaningful for troubleshooting?

If I can't get this working, I'd be looking to get a refund of the license on the software.
I was forced to purchase license because the trial counted each sync button press as "new device connected" and wore out my attempts.

Michael
.

No there are no refunds and you are not forced to buy this software. If you run out then you email me or post a question like everyone else does

jkoros
.

Are there any other logs I should look for?

Are the errors I posted meaningful for troubleshooting?

Michael
.

The problem is that android doesnt have full control over a USB device (as much as linux does), so there is nothing that can be "turned on" to log things, like there is in normal linux. Do you have a raspberry pi or something like that? If so that can run the virtualhere server also and is very good.

jkoros
.

I will look at adding a raspberry pi as an alternative.
Would the newer dongle be more stable/guaranteed to work?

Michael
.

OK i spent a few hours today investigating this further. I have the same adapter i use for testing. I plugged it into my shield and used it via virtualhere then it disappeared and wouldn't work and the light wouldn't go on.

So i plugged the adapter into my laptop and it still did the same thing! And it was impossible to sync with my xbox controller

This all used to work fine, so i checked the drivers and i notice a new updated one xboxgip.sys from the end december 2020. So i suspect there is something wrong with that update that microsoft did. I see a lot of issues on the internet related to xboxgip.sys and BSOD and weird problems with it e.g (https://www.google.com/search?q=xboxgip.sys)

So i suspect its actually some problem in that particular driver and it wont matter if you use a pi. (As i said i couldn't even get it to work on my laptop normally, directly plugged in and not via virtualhere)

I think you will need to wait until that driver is fixed by microsoft.

If your controller has bluetooth and you have a bluetooth adapter you can try that method and use the bluetooth adapter via virtualhere and sync that way

jkoros
.

Thanks for the continued troubleshooting.

I was able to get the dongle to light up on my old desktop, but have not been able to get it to work when plugged in directly to my newer rig either.
I will install virtualhere on the old one and see if I'm able to get it to sync as expected on the shield so we can close this issue as not a virtualhere server problem.

I think you're right Microsoft broke something with the driver update since my old pc has the old drivers.
I'll follow up with MS forums too.

jkoros
.

I have just confirmed it is a problem with the windows driver not responding to my adapter.
VirtualHere is working correctly and passing the device.
When plugged in to the old pc with the older driver installed, it recognizes the adapter and lights up as expected.

Thanks again for the help in troubleshooting. Will have to bug microsoft for the fix.

Michael
.

Thanks for letting me know

Log in or register to post comments