Eaton Ellipse PRO 650 UPS unable to use?

17 posts / 0 new
Last post
edwin2021
Eaton Ellipse PRO 650 UPS unable to use?

Hi,

Took a raspberry pi 3B (not the +) and burned img on to it an got it running (trial version) directly connected via ethernet cable. Fixed IP from router.
From a w10x64 box i used the client and are able to see and use a USB flash disk.

Now the challenge using a Eaton UPS with it's own software
Eaton UPS Companion allows easy shutdown parameters configuration and user friendly access to UPS settings.
https://powerquality.eaton.com/Products-services/Power-Management/Softwa...
Eaton Intelligent Power Protecto Avoid data loss by gracefully shutting down computers and virtual machines/servers powered by an Eaton UPS during an extended power outage
https://powerquality.eaton.com/products-services/power-management/softwa...

VH Client show "Ellipse PRO" but keep's on disconnecting (the txt "in use by you" disapeares)

VENDOR: EATON
PRODUCT: Ellipse PRO
VENDOR ID: 0x0463
PRODUCT ID: 0XFFFF
SERIAL: P355J15JC1
ADDRESS: 115

Even when connected the Eaton software is not able to connect.

Any chance on getting this working?

Regards,
Edwin

Michael
.

Right click on the UPS in the virtualhere client and select Custom Event Handler... and paste in exactly this line:

onReset.$VENDOR_ID$.$PRODUCT_ID$=

then press ok. Now try to use it via virtualhere, does it work ok?

edwin2021
Nop, software of eaton still

Nop, software of eaton still says "Communication with UPS has failed"
And VH Client disconnects after short period of time

Michael
.

OK one other thing to try

Stop the virtualhere server on the pi and then edit the config.ini on the server and add the line

ClaimPorts=1

Then start the server again and then try to use the UPS via virtualhere.

There is one other thing to try if that still doesnt work. It involves turning off USB powermanagement for that device in windows. See a response to a similar issue recently https://www.virtualhere.com/comment/9142#comment-9142

edwin2021
I assume via putty or winscp.

I assume via putty or winscp. Which credentials should i use?

Michael
.

I assume you are using the cloudhub image? If so username is "root" and no password

edwin2021
allright, linux newbie.

allright, linux newbie.
Managed to get into pi with winscp.
How to stop (and start) the service so i can edit the config file?

Michael
.

OK i think this is a bit advanced if you dont know linux and this is not really a how to use linux forum. So virtualhere is not going to work with this device sorry.

edwin2021
@Michael

Hey, i'm working as IT guy but just windows based. I found some info in the forum but it seems outdated.
So instead of digging around a pointer in the right direction would be apriciated.
If purchasing a licence is the problem then just say so. I think virtualhere is an amzing product and worth every penny despite the price rais over the years.

edwin2021
Figured it out. Just for

Figured it out. Just for reference for someone else
service vhusbd stop
edit config.ini
service vhusbd start

edwin2021
tried it all

Hi Michael,
I tried the config change with ClaimPorts=1 and the reg change. found the keys twice:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\VID_0B0E&PID_030D&MI_03\3&cdc4d77&0&0003\Device Parameters
Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\VID_0463&PID_FFFF\P355J15JC1\Device Parameters
Still the server disconnects the client. Like before the eaton UPS service has never been able to connect to the UPS.

Michael
.

Yes ok good!, actually the ClaimPorts=1 you add that line to the server side config.ini file in /root/config.ini on the server

Then save and reboot the server pi and see if that fixes it

edwin2021
rebooted the pi

rebooted the pi
removed the eaton software on de the w10 box (so that windows would pickup the ups)
Sad to say, no go. Everything seems ok, even device management gives no errors, but no ups usable in windows. Device management show's a Eaton USB devices\Eaton UPS 0463-L

Michael
.

OK thats unfortunate. I dont know what else to try. I assume you have the very latest firmware/software for that device installed https://powerquality.eaton.com/Support/Software-Drivers/default.asp

edwin2021
.

Bummer...
Was hoping i could monitor the UPS which is powering several raspberries in the cellar from a workstation on one off the upper level's.
Also providing a way in the future to monitor the UPS from within a virtual box running on ESXi.

Michael
.

You could maybe try emailing eaton. They might listen to their customers and make a slight change to their software so it can see the device sent via virtualhere.

edwin2021
will try

will try

Log in or register to post comments