Honeycomb Alpha Flight Controls

16 posts / 0 new
Last post
poxbottle
Honeycomb Alpha Flight Controls

Hi,
I'm unable to get my Honeycomb Alpha Flight Controls working with VirtualHere. It will momentarily connect then disconnect.
here are the logs from the server (Win 10 x64):

2020-03-04 23:00:45 INFO :Connection 1 successfully removed (reason:server shutdown)
2020-03-04 23:00:45 INFO :Connection 1 successfully removed (reason:timeout)
2020-03-04 23:00:47 INFO :Unmanaging device 26 [294b:1900]
2020-03-04 23:00:47 INFO :Unmanaging device 21 [1532:021e]
2020-03-04 23:00:47 INFO :Unmanaging device 22 [093a:2521]
2020-03-04 23:00:47 INFO :Unmanaging device 23 [06a3:0763]
2020-03-04 23:00:47 INFO :Unmanaging device 17 [06a3:0c2d]
2020-03-04 23:00:47 INFO :Unmanaging device 5 [0bda:0129]
2020-03-04 23:00:47 INFO :Unmanaging device 6 [8087:0a2a]
2020-03-04 23:00:47 INFO :Unmanaging device 7 [0d8c:0014]
2020-03-04 23:00:48 INFO :>>> Shutdown <<<
2020-03-04 23:00:57 INFO :>>> Starting VirtualHere USB Server v4.1.0 (Built: Feb 24 2020, 17:24:04)<<<
2020-03-04 23:00:57 INFO :Using configuration C:\Users\bean_\Downloads\config.ini
2020-03-04 23:00:57 INFO :Server licensed to=unlicensed max_devices=1
2020-03-04 23:00:57 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2020-03-04 23:00:57 INFO :Tickled device USB\VID_0BDA&PID_0129\20100201396000000 when getting prod/vend strings
2020-03-04 23:00:58 INFO :Tickled device USB\VID_8087&PID_0A2A\5&1304F410&0&7 when getting prod/vend strings
2020-03-04 23:00:58 INFO :Found Full speed device [294b:1900] "Honeycomb Aeronautical, Alpha Flight Controls" at address 26
2020-03-04 23:00:58 INFO :Found Full speed device [1532:021e] "Razer, Razer Ornata Chroma" at address 21
2020-03-04 23:00:58 INFO :Found Low speed device [093a:2521] "0x093a, USB OPTICAL MOUSE" at address 22
2020-03-04 23:00:58 INFO :Found Full speed device [06a3:0763] "Saitek, Saitek Pro Flight Rudder Pedals" at address 23
2020-03-04 23:00:58 INFO :Found Full speed device [06a3:0c2d] "Saitek, Saitek Pro Flight Quadrant" at address 17
2020-03-04 23:00:58 INFO :Found High speed device [0bda:0129] "Generic, USB2.0-CRW" at address 5
2020-03-04 23:00:58 INFO :Found Full speed device [8087:0a2a] "0x8087, 0x0a2a" at address 6
2020-03-04 23:00:58 INFO :Found Full speed device [0d8c:0014] "C-Media Electronics Inc., USB Audio Device" at address 7
2020-03-04 23:01:21 INFO :192.168.2.1 connected as connection 1
2020-03-04 23:02:02 INFO :Device 26 [294b:1900] BOUND to connection 1
2020-03-04 23:02:03 WARNING :Failed to release claimed device USB\VID_0BDA&PID_5411\5&1304F410&0&6,USB\VID_294B&PID_1900\53FE381811243B00,1 while uncapturing, The device does not recognize the command. (0x00000016)
2020-03-04 23:02:06 INFO :Device 26 [294b:1900] SURPRISE UNBOUND from connection 1
2020-03-04 23:02:06 INFO :Unmanaging device 26 [294b:1900]
2020-03-04 23:02:06 INFO :Found Full speed device [294b:1900] "Honeycomb Aeronautical, Alpha Flight Controls" at address 26

Any ideas?

Michael
.

Right click on the HoneyComb Flight Controls in the VirtualHere Client then select Custom Event Handler... then paste in this line and click OK

onReset.$VENDOR_ID$.$PRODUCT_ID$=

Now unplug/replug the controls and try using it again via virtualhere

poxbottle
Thanks for that but

Thanks for that but unfortunately i got the same result: Logs below

2020-03-05 08:39:36 INFO :>>> Starting VirtualHere USB Server v4.1.0 (Built: Feb 24 2020, 17:24:04)<<<
2020-03-05 08:39:37 INFO :Using configuration C:\Users\bean_\Downloads\config.ini
2020-03-05 08:39:37 INFO :Server licensed to=unlicensed max_devices=1
2020-03-05 08:39:37 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2020-03-05 08:39:38 INFO :Tickled device USB\VID_0BDA&PID_0129\20100201396000000 when getting prod/vend strings
2020-03-05 08:39:38 INFO :Tickled device USB\VID_8087&PID_0A2A\5&1304F410&0&7 when getting prod/vend strings
2020-03-05 08:39:38 INFO :Found Full speed device [294b:1900] "Honeycomb Aeronautical, Alpha Flight Controls" at address 26
2020-03-05 08:39:38 INFO :Found Full speed device [1532:021e] "Razer, Razer Ornata Chroma" at address 21
2020-03-05 08:39:38 INFO :Found Low speed device [093a:2521] "0x093a, USB OPTICAL MOUSE" at address 22
2020-03-05 08:39:39 INFO :Found Full speed device [06a3:0763] "Saitek, Saitek Pro Flight Rudder Pedals" at address 23
2020-03-05 08:39:39 INFO :Found Full speed device [06a3:0c2d] "Saitek, Saitek Pro Flight Quadrant" at address 17
2020-03-05 08:39:39 INFO :Found High speed device [0bda:0129] "Generic, USB2.0-CRW" at address 5
2020-03-05 08:39:39 INFO :Found Full speed device [8087:0a2a] "0x8087, 0x0a2a" at address 6
2020-03-05 08:39:39 INFO :Found Full speed device [0d8c:0014] "C-Media Electronics Inc., USB Audio Device" at address 7
2020-03-05 08:41:15 INFO :192.168.2.1 connected as connection 1
2020-03-05 08:41:56 INFO :Set custom event "onReset.294b.1900="
2020-03-05 08:41:58 INFO :Unmanaging device 26 [294b:1900]
2020-03-05 08:42:02 INFO :Found Full speed device [294b:1900] "Honeycomb Aeronautical, Alpha Flight Controls" at address 26
2020-03-05 08:42:14 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:14 INFO :Device 26 [294b:1900] BOUND to connection 1
2020-03-05 08:42:14 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:15 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:16 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:16 WARNING :Failed to release claimed device USB\VID_0BDA&PID_5411\5&1304F410&0&6,USB\VID_294B&PID_1900\53FE381811243B00,1 while uncapturing, The device does not recognize the command. (0x00000016)
2020-03-05 08:42:16 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:17 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:17 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:18 INFO :Device 26 [294b:1900] SURPRISE UNBOUND from connection 1
2020-03-05 08:42:18 INFO :Unmanaging device 26 [294b:1900]
2020-03-05 08:42:18 INFO :Found Full speed device [294b:1900] "Honeycomb Aeronautical, Alpha Flight Controls" at address 26
2020-03-05 08:42:26 INFO :Set custom event "onReset.294b.1900="
2020-03-05 08:42:29 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:29 INFO :Device 26 [294b:1900] BOUND to connection 1
2020-03-05 08:42:29 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:30 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:30 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:30 WARNING :Failed to release claimed device USB\VID_0BDA&PID_5411\5&1304F410&0&6,USB\VID_294B&PID_1900\53FE381811243B00,1 while uncapturing, The device does not recognize the command. (0x00000016)
2020-03-05 08:42:31 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:32 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:32 INFO :Executed empty hook for onReset.294b.1900
2020-03-05 08:42:32 INFO :Device 26 [294b:1900] SURPRISE UNBOUND from connection 1
2020-03-05 08:42:32 INFO :Unmanaging device 26 [294b:1900]
2020-03-05 08:42:32 INFO :Found Full speed device [294b:1900] "Honeycomb Aeronautical, Alpha Flight Controls" at address 26

Michael
.

OK i dont think its going to work via virtualhere. The device does not seem to like to be redirected for some unknown reason.

BChirhart
Honeycomb Alpha Flight Controls

As in, it won't ever work? Is this something that VirtualHere can research or does something need to change from Honeycomb (mfg of the yolk).

Michael
.

I dont know. It might work at some point, but i dont have that device to test with and its too expensive to just buy it for this test.

Oli80
update?

Morning,
I find myself in the same situation where the Honeycomb is not being recognised by the virtual PC. Were you able to fix it? I've been in touch with Honeycomb who are looking into it but so far no luck..
Thanks.

Michael
.

No i havent heard anything as of today

Oli80
.

Thanks Michael.
A friend of mine has successfully got VirtualHere up and running on his Shadow PC with his Honeycomb Alpha connected and working (since about Feb this year I believe). We both run iMac's from early 10's so I'm a little stumped as to why it isn't working on my machine. Honeycomb have come back to me and said that nothing has changed since the manufacturing date for my friend's Honeycomb and mine (firm- and hardware hasn't changed).
My only remaining option I think is that this may be an issue with OSX? The last remaining difference seems to be that I am running Mojave on my 2012 iMac and he is running El Capitan on his 2010 iMac. Although he says it works just as well on his MPB running Catalina. Do you know if anything changed with these releases of OSX?
Thank you.

Michael
.

Anything after 10.10 is more and more broken, apple has changed USB support in each version since then. Ask your friend to email his server config.ini file and paste its contents in here. Perhaps there is a setting that hes using that you dont have. The server config.ini file is usually in your home directory.

Oli80
Update

Hi Michael,
An update for you, I installed the VirtualHere server on my work laptop (Windows 10 machine) and tried to connect from my iMac across my local network - This worked and I was able to use the Honeycomb device. Clearly it does accept redirecting from a Windows 10 machine.
I then changed the port forwarding on my router to my laptop and connected to it from my Shadow PC. I got the same errors as previously leading me to believe that it has something to do with USB latency (ping is about 120ms to the Shadow PC). I executed the event handler you listed above and tried again and it didn't work. I then deleted the event handler and thought I'd try one more time and it worked...

I've been testing it since and it seems very hit and miss when it does and doesn't work. Sometimes it does work with the event handler, sometimes it doesn't. Sometimes it works after deleting the event handler. The log file on the server side doesn't show any of the errors that others have reported above - all seems to be working normally.

FYI the config file my friend sent me below (it doesn't seem to contain an awful lot which makes me wonder whether this is the correct file?):
It=1586606647
EasyFindId=xxx
EasyFindPin=xxx
EasyFindKey=xxx
License=xxxxxxx
EasyFind=0

I guess you can't connect to two servers on the same network simultaneously? I have most USB devices plugged into my iMac working normally and the Honeycomb connected to my work PC. My port forwarding is currently setup to my PC so I assume I can't set it up twice? Or maybe change the port forwarding to another port for my iMac? What would you recommend?

Thank you.

Michael
.

OK it sounds like its almost certainly a latency issue. 120ms is very high. You really need <50ms or <20ms ideally.

Your friends config.ini file looks fine and doesn't have any special settings this is why i'm leaning towards a network latency problem rather than a device/virtualhere issue specifically.

A single virtualhere client can connect to any number of virtualhere servers simultaneously there is no limitation there, not sure why you cant connect to two servers on the same network.

Why is your latency so high, im not entirely familiar with shadow but dont they have data centres around the place? Or are you stuck at this data centre to run the game?

Oli80
.

Hi Michael,
The latency is high because I'm currently based out of the UAE and the Shadow PC is located in Paris... it's the closest option. And even though 120ms is high, for my flightsim needs it is perfectly useable.
Do you recommend using certain port numbers to connect to a second VirtualHere server? I can do it by simply setting up a second port forwarding rule on my router.
Thanks.

Michael
.

Its probably going through some sort of deep inspection firewall or something, in those types of countries. I know Chinese users have issues sometimes with virtualhere going through the chinese firewall.

Anyway port 7575 is the TCP port the virtualhere uses so you need to open that.

Oli80
.

I'm currently using 7575 for my iMac and the VirtualHere server there.
Could I use 7576 for my PC VirtualHere server?
Thank for your patience.

Michael
.

You could but it wont work with the free version of the server

Log in or register to post comments