No connection to client possible. Raspberry Pi 4 Model B with 4.1.0

19 posts / 0 new
Last post
fliegerhorst
No connection to client possible. Raspberry Pi 4 Model B with 4.1.0

Wifi is there but client can not connect with the new firmware. ..also IP:7575 dosen't help. I tried it also with an other pc same effect. If I flash the older image no problem.

Michael
.

Sorry fixed now, ive now re-uploaded the correct firmware for 4.1.0

fliegerhorst
Super fast work now. thx

Super fast work now. thx
case solved

MarkoD
Sorry to hijack this thread,

Sorry to hijack this thread, but after updating to 4.1.0 from 4.0.9 (CloudHub on GL300), I see this message in the logs:

Sun Mar 1 00:52:15 2020 kern.warn kernel: [ 36.042270] jffs2: Erase at 0x00bb0000 failed immediately: errno -22

Michael
.

@MarkoD download the image again and try this updated version

MarkoD
@Michael: Thanks for the

@Michael: Thanks for the quick reply, I've flashed the updated image, however the message is still there - even tried rebooting the unit a couple of times.

Michael
.

Ok actually i dont think that message is important. Did the software update anyway correctly? I.e from 4.0.9 to 4.1.0

MarkoD
I did the update from 4.0.9

I did the update from 4.0.9 to 4.1.0 via the Windows client and there were no error messages. Should I try to reset the unit to factory and flash 4.1.0 again?

The log entry appears only once (approx. 30 seconds after startu-up), USB redirection works correctly.

I've tried downgrading back to 4.0.9 (flashed older image via VH clinet), which went through, however dnsmasq cannot start:

Mon Mar 2 16:00:06 2020 daemon.crit dnsmasq[1268]: directory /tmp/resolv.conf.d/resolv.conf.auto for resolv-file is missing, cannot poll
Mon Mar 2 16:00:06 2020 daemon.crit dnsmasq[1268]: FAILED to start up

Maybe there are different steps for downgrading?

Regards,

Marko

Michael
.

The upgrade worked, don't worry about those messages

MarkoD
I've tried updating from 4.0

I've tried updating from 4.0.9 back to the latest 4.1.0 image, however nothing happens if I try to do it via the GUI (the unit does not restart). I've tried uploadng the image and running sysupgrade, but I get this error:


Image not in /tmp, copying...
Device glinet,gl-mt300n-v2 not supported by this image
Supported devices: gl-mt300n-v2
Image check failed.

Do you know what could be wrong? I went this path: 4.0.9 -> 4.1.0 -> 4.0.9 and now I' trying to flash it back to 4.1.0.

Michael
.

OK something is buggy in openwrt at the moment so i rolled back to 18.06.7 however you will need to force the update like this

ssh to the router and type

sysupgrade --force /path/to/firmware.bin

MarkoD
Thanks, this is what I've

Thanks, this is what I've done:
- flashed 4.1.0 using --force, which worked, however all the dnsmask log warning were there
- flashed the original GL-MT300N-V2 firmware using --force, which somehow rebooted into a bricked state, however by resetting the unit a couple of times (using the reset button) brought it to life
- flashed 4.1.0 again via the web UI

Now I have 4.1.0 and I have no warnings or errors in the log (dnsmasq or jffs2) :-). I've used the same (updated) 4.1.0 image with SHA1: CEA50E97A6E2E3004C052D376D21F62E5E4FCD08, VirtualHere USB Server v4.1.0 (Built: Mar 1 2020, 13:57:58).

So I guess errors in the log were upgrade-specific from 4.0.9 to 4.1.0?

Michael
.

Just tested again, something is still wrong updateng from 4.0.9 to 4.1.0 ill work on this now...

MarkoD
Hi, I noticed 4.1.1 just came

Hi, I noticed 4.1.1 just came out - is it okay to upgrade from 4.0.9 to 4.1.1?

Michael
.

You need to write the original gl-inet firmware over 4.0.9 then upgrade to 4.1.1 like normal

MarkoD
Thanks, will report back.

Thanks, will report back. What about when upgrading from 4.1.0 to 4.1.1?

Michael
.

That will work ok

MarkoD
Hi, reporting back - upgrade

Hi, reporting back - upgrade from 4.1.0 to 4.1.1 went smooth, no errors in the log.

Michael
.

OK great thanks for letting me know!

Log in or register to post comments