Virtualhere not working or showing G25

11 posts / 0 new
Last post
jvalente
Virtualhere not working or showing G25

Hi All,

I have a steamlink and have tried to connect my G25 to it and use virtualhere to connect the device.

However, when I run virtualhere after connecting the G25 wheel to my steam link, no devices show and I sometimes get an error as below.

The error i get is:

../src/msw/toplevel.cpp(1544): assert "m_menuDepth > 0" failed in
DoSendMenuOpenCloseEvent(): No open menus?
Do you want to stop the program?
You can also choose [Cancel] to suppress further warnings.

No devices ever show under virtualhere as well...

Michael
What version of the client

What version of the client are you running? Can you make sure that you are using at least version 3.6.3 ( as that bug was in 3.6.2 )

jvalente
Running version 3.6.3

Hi michael,

I am running version 3.6.3. Not sure what was happening, but when I first ran virtualhere, it asked me to install Bonjour (which I had stopped running in Msconfig).

After I re-enabled bonjour and re-ran Virtualhere, it did an install, but found my bonjour version to be a later version and did nothing.

Now when I run bonjour, nothing happens

jvalente
Current system log

19:22:04 INFO :VirtualHere Client 3.6.3 starting (Compiled: May 19 2016 11:52:25)
19:22:04 INFO :Using config at C:\Users\jtiag_000\AppData\Roaming\vhui.ini
19:22:04 INFO :IPC available at \\.\pipe\vhclient
19:22:04 INFO :Auto-find (Bonjour) on
19:22:04 INFO :Auto-find (Bonjour SSL) on
19:22:05 INFO :Drivers are up-to-date

Michael
OK so you stopped the

OK so you stopped the installation of bonjour, but now its installed. (You must install bonjour so the steamlink can be automatically found)

Just wait a minute or so for it to find the steamlink. You MUST be running steamlink beta. Can you verify that you are running the steamlink beta? If you dont not run the beta then virtualhere wont be on the steamlink.

If it doesnt automatically appear, you can also Specify the ip address of the steamlink directly in the virtualhere client by right clicking USB Hubs->Specify Hubs and putting the steamlink ip address in there.

In the next week or so virtualhere will be moved out of beta into a normal steamlink app (which costs money) but the installation will be simpler and more automatic

jvalente
Hi, I was running steam link

Hi, I was running steam link beta.

I am a bit of a noob when it comes to IP addresses. How can I find out which IP address steam link is running?

Michael
Its in Steam Link menu ->

Its in Steam Link menu -> Settings -> Network IP address

I tested on my steamlink firmware 517 beta, and virtualhere seems not to start on there automatically. Im not sure of the setup valve has but basically I think you might have to wait until virtualhere is out of beta probably in the next week or two. Then you can just buy it in the steam shop

jvalente
Thank you

Thanks Michael,

I'll try the IP address method you mention above.

But you're saying that method may still not work?

Michael
When i switched to beta the

When i switched to beta the virtualhere server was not started on the steamlink. So it didnt matter if it put the ip address or let the virtualhere client automatically find it

jvalente
Yeah it didn't work

Yeah after inputting the IP address, nothing happens.

I've seen in earlier videos people say to enable USB sharing. But this option seems to be gone

Michael
ok, i think you might have to

ok, i think you might have to wait for a week or two for it to be out of beta in put into the steam store

Log in or register to post comments