Error after sleep on mac

After my M1 Mac has been to sleep overnight

I see this in system messages (and a new one appearing every couple of seconds or so):

2022-10-09 13:38:11 INFO  :Did not find device to unbind!
2022-10-09 13:38:12 INFO  :There are no more virtual ports available, all 15 in-use
2022-10-09 13:38:14 INFO  :Did not find device to unbind!
2022-10-09 13:38:14 INFO  :There are no more virtual ports available, all 15 in-use
2022-10-09 13:38:16 INFO  :Did not find device to unbind!

 

And this in the virtual here client:

Error "Operation not permitted" (-1) trying to use this device (raspberrypi.local:7575)

And in the main window I see the hub, with the device changing from 

iLok to iLok (In use by you) and back again every couple of seconds or so

quitting the client and re-running it fixes it.

 

 

#2

Could you stop and exit the virtualhere client then download and run this test version instead

https://www.virtualhere.com/sites/default/files/usbclient/test/VirtualH…

Then after the mac goes to sleep overnight and wakes up again could you post the system messages by right clicking USB Hubs->System Messages->Copy to clipboard and paste in here.

Thanks!

#3

Hi,

I've done that and it looks like a few connections an hour, probably when the device wakes up regularly. I know my network takes a few seconds to come up when the device wakes, I'd hope virtualhere would just re-establish the connection when it can, but it seems to do that for a few times then declare it's out of connections - like all the previous ones are still open?

#4

Thanks for that i will investigate the log, (ive removed it from this post)

#5

I made another test version

Could you stop and exit the existing virtualhere client, then download this new test version https://www.virtualhere.com/sites/default/files/usbclient/test/VirtualH…

and send me the logs again when it wakes up.  Can you email them to mail [at] virtualhere.com as the log will be more verbose as ive turned on more logging where i think the bug might be.

#6

I've sent logs (subject: "Mac Sleep Issue Logs")

I've noticed it can be reproduced quicker, but quickly sleeping and waking the Mac - consuming 1/16 connections each time. Otherwise I think it's happening when the MacBook enters dark wake mode each time during the night.

Thanks,

Anthony

#8

Ive posted this update to the main website now as 5.4.1 as im pretty sure this fixes the issue